PHP 5.2.17 detected, 5.3.0 or above required.

You need to upgrade PHP engine installed on your server. If it's a dedicated or your local server, you can download the latest version of PHP from its official site and install it yourself. In case of a shared hosting, you need to ask your hosting provider to perform the upgrade.